<!DOCTYPE html>
<html lang="en" xml:lang="en">
  <head>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/>
    <link rel="amphtml" href="https://www.haverhillecho.co.uk/sport/amp/gibbs-at-the-double-as-rovers-end-wait-for-win-in-the-league-9087772/"/>
    <meta property="article:published_time" content="2019-10-30Z15:30:00.0000000+00:00"/>
    <meta property="article:tag" content="Football"/>
    <link rel="canonical" href="https://www.haverhillecho.co.uk/sport/gibbs-at-the-double-as-rovers-end-wait-for-win-in-the-league-9087772/"/>
    <meta name="original-source" content="https://www.haverhillecho.co.uk/sport/gibbs-at-the-double-as-rovers-end-wait-for-win-in-the-league-9087772/"/>
    <meta property="og:url" content="https://www.haverhillecho.co.uk/sport/gibbs-at-the-double-as-rovers-end-wait-for-win-in-the-league-9087772/"/>
    <meta name="description" content="Haverhill side return three points in league for first time in seven tries to put a stop to bad run."/>
    <meta name="keywords" content="Football"/>
    <meta property="og:locale" content="en_GB"/>
    <meta property="og:description" content="Haverhill side return three points in league for first time in seven tries to put a stop to bad run."/>
    <meta property="og:title" content="Gibbs at the double as Rovers end wait for win in the league"/>
    <meta property="og:type" content="article"/>
    <meta property="og:site_name" content="Haverhill Echo"/>
    <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "articleSection": "Sport",
        "headline": "Gibbs at the double as Rovers end wait for win in the league\r",
        "keywords": [
          "Football"
        ],
        "thumbnailUrl": "https://www.haverhillecho.co.uk/_media/img/30UZ1BFGCPSMERYZ31CJ.jpg",
        "author": {
          "@type": "Person",
          "name": "Liam Apicella"
        },
        "creator": {
          "@type": "Person",
          "name": "Liam Apicella"
        },
        "publisher": {
          "@type": "Organization",
          "logo": {
            "@type": "ImageObject",
            "url": "https://www.haverhillecho.co.uk/site-logo.png"
          },
          "name": "Haverhill Echo"
        },
        "dateCreated": "2019-10-30T13:35:48.456397Z",
        "dateModified": "2019-10-30T15:09:01.179978Z",
        "datePublished": "2019-10-30T15:30:00Z",
        "image": "https://www.haverhillecho.co.uk/_media/img/30UZ1BFGCPSMERYZ31CJ.jpg",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": "https://www.haverhillecho.co.uk/sport/gibbs-at-the-double-as-rovers-end-wait-for-win-in-the-league-9087772/"
        },
        "url": "https://www.haverhillecho.co.uk/sport/gibbs-at-the-double-as-rovers-end-wait-for-win-in-the-league-9087772/"
      }
    </script>
    <meta property="og:image" content="https://www.haverhillecho.co.uk/_media/img/30UZ1BFGCPSMERYZ31CJ.jpg"/>
    <meta property="og:image:width" content="1570"/>
    <meta property="og:image:height" content="1080"/>
    <title>Gibbs at the double as Rovers end wait for win in the league</title>
    <script type="text/javascript" src="/_bundles/iliffe-base-v5155844.js"></script>
    <link type="text/css" rel="stylesheet" href="/_resources/commentsv3-v5168835.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/font-awesome-svg-5.10.2-v5099857.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/iliffe_gallery_carousel-v4934161.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/iliffe-he-v5169030.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/WeatherIcons-v4482099.css"/>
    <script type="text/javascript" src="/_resources/common-v5137428.js"></script>
    <script type="text/javascript" src="https://cdn.conversant.mgr.consensu.org/gdpr/cmp/config/h/a/haverhillecho.co.uk/config.js"></script>
    <script type="text/javascript" src="/_resources/flux-v3.1.3-v5085464.js"></script>
    <script type="text/javascript" src="/_resources/iliffe_gallery_carousel-v4934147.js" defer></script>
    <script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script type="text/javascript" src="/_resources/moment-v5086699.js"></script>
    <script type="text/javascript" src="https://platform.twitter.com/widgets.js" async></script>
    <script type="text/javascript" src="/_resources/vue-v2.6.10-v5128841.js"></script>
    <script type="text/javascript" src="https://secure-cdn.mplxtms.com/gdpr/cmp/gdpr-cmp-bootstrap.js"></script>
    <script type="text/javascript" src="/_resources/commentsv3-v5155892.js"></script>
    <script type="text/javascript" src="https://cdn.mediavoice.com/nativeads/script/klmedia/km_master.js" async></script>
    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/apple-touch-icon-152x152-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/apple-touch-icon-144x144-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/apple-touch-icon-120x120-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/apple-touch-icon-114x114-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/apple-touch-icon-76x76-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/apple-touch-icon-72x72-precomposed.png">
    <link rel="apple-touch-icon-precomposed" href="/apple-touch-icon-precomposed.png">
    <script type="text/javascript">
      var pluginsConfig = {
        "Cmp" : true,
        "Comscore" : {
          "C1" : "2",
          "C2" : "6035892"
        },
        "Lotame" : {
          "Code" : "12965"
        },
        "Piano" : {
          "Code" : "THcDeNjzJX"
        },
        "Taboola" : {
          "Url" : "https://cdn.taboola.com/libtrc/mediaforceeurope-network/loader.js",
          "MobileSelector" : "taboola-below-article-thumbnails-mobile",
          "MobileFeed" : "Below Article Thumbnails Feed",
          "DesktopSidebarSelector" : "taboola-right-rail-thumbnails",
          "DesktopSidebarFeed" : "Right Rail Thumbnails",
          "DesktopBodySelector" : "taboola-below-article-thumbnails",
          "DesktopBodyFeed" : "Below Article Thumbnails Feed"
        }
      };
    </script>
    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-117714806-1', 'auto');
      ga('send', 'pageview');
    </script>
    <script type="text/javascript">
      var dfpConfig = { DesktopUnit: "~154725070~haverhillecho_desktop~sport", MobileUnit: "~154725070~haverhillecho_mobile~sport" };
    </script>
  </head>
  <body class="responsive">
<header id="header"> <div id="headerSearch"> <form class="search s top" method="get" action="/search/"> <div class="row"> <div class="offset-lg-3 col-lg-6"> <input class="typesearch sb" type="text" name="q" placeholder="What would you like to find?"/> <button type="submit" class="sbtn"><i class="fas fa-search fa-2x"></i></button> </div> </div> </form> </div><div class="mobilemenu d-lg-none"> <div class="row no-gutters mobilemenu navbar"> <div class="col-2 account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> <div class="col-6 col-sm-4 col-md-3"> <a class="navbar-brand m-0 p-0" href="/"> <img src="/_assets/haverhillecho.svg" class="img-fluid mx-auto d-block mainlogo" alt="Haverhill Echo"/></a> </div> <div class="col-1 searchmob"> <div id="dropmobile"><a class="btn-search droptoggle" data-toggle="collapse"><i class="fas fa-search"></i></a> </div> </div> <div class="col-2 white text-center"> <button type="button" class="navbar-toggler w-100" data-toggle="collapse" data-target=".navbar-collapseMobile">&#x2630;</button> </div> </div> <div class="collapse navbar-collapseMobile" id="navbarSupportedContentMobile"> <div> <div class="topmenu"> <div class="text-center mobilenumber"> <i class="fas fa-phone fa-flip-horizontal"></i> <a href="tel:01440-761307">01440 761307</a> </div> <div class="whitethindiv"></div> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="https://www.destinationeastanglia.co.uk" target="_blank">Destination East Anglia</a></li> <li>|</li> <li><a href="/announcements/">Announcements</a></li> <li>|</li> <li><a href="https://property.haverhillecho.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="http://haverhill.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="/_assets/iliffe-media-pack-october-2019.pdf" target="_blank">Media Info</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> <li>|</li> <li><a href="/contact-us/">Contact us</a></li> <li>|</li> <li><a href="https://twitter.com/haverhill" target="_blank"><i class="fab fa-twitter"></i></a></li> <li>|</li> <li><a href="https://www.facebook.com/Haverhill-Echo-744187595656988/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> </ul> </div> <div class="clearfix"></div> <div class="row no-gutters mobweather pb-2"> <div class="mx-auto text-left width"><a href="/weather/"> <i class="wi wi-night-alt-cloudy float-left" alt="Partly Cloudy"></i> <div class="WeatherHomeInfo"> <span class="Temp">11&deg;</span><span class="TempLater"> | 2&deg; - 5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> <ul class="p-2 dropnav"><li><span><a href="/">Home</a></span></li> <li class="menuParent"> <span>News <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/">News</a></li> <li><a href="/news/business/">Business</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/your-say/">Your Say</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=1f260fe5-e40b-4ada-afd1-263c1a0e9a40" target="_blank">E-edition</a></li> </ul> </div> </li> <li class="menuParent"> <span>Sport <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/sport/">Sport</a></li> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/cricket/">Cricket</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Lifestyle <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/lifestyle/">Lifestyle</a></li> </ul> </div> </li> <li class="menuParent"> <span>What's On <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/whats-on/">What's On</a></li> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Directory <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/directory/">Directory</a></li> </ul> </div> </li> <li class="menuParent"> <span>Jobs <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></li> </ul> </div> </li> <li class="menuParent"> <span>Velvet Mag <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="https://www.velvetmag.co.uk/" target="_blank">Velvet Mag</a></li> </ul> </div> </li></ul> </div> </div> </div><div class="desktopmenu d-none d-lg-block"> <nav class="navbar navbar-expand-lg navbar-light top" id="menu"> <div class="container"> <div class="row no-gutters w-100"> <div class="col-lg-11"> <div class="FirstMenu"> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="https://www.destinationeastanglia.co.uk" target="_blank">Destination East Anglia</a></li> <li>|</li> <li><a href="/announcements/" target="_blank">Announcements</a></li> <li>|</li> <li><a href="http://haverhill.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="https://property.haverhillecho.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=1f260fe5-e40b-4ada-afd1-263c1a0e9a40" target="_blank">E-edition</a></li> <li>|</li> <li><a href="/_assets/iliffe-media-pack-october-2019.pdf" target="_blank">Media Info</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> <li>|</li> <li><a href="/contact-us/">Contact us</a></li> </ul> </div> </div> <div class="col-lg-1 text-right socialsearch"> <ul> <li><a href="https://twitter.com/haverhill" target="_blank"><i class="fab fa-twitter"></i></a></li> <li><a href="https://www.facebook.com/Haverhill-Echo-744187595656988/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> <li class="d-none d-sm-block"> <div id="drop"><a class="btn-search droptoggle"><i class="fas fa-search"></i></a></div> </li> </ul> </div> </div> </div> </nav> <div class="LogoSection"> <div class="container"> <a href="/"> <img src="/_assets/haverhillecho.svg" alt="Haverhill Echo" class="main-logo"/></a> <div class="WeatherHome float-right d-none d-sm-none d-lg-block"><a href="/weather/"> <i class="wi wi-night-alt-cloudy float-left" alt="Partly Cloudy"></i> <div class="WeatherHomeInfo"> <span class="Temp">11&deg;</span><span class="TempLater">| 2&deg;</span> <div class="clearfix" style="height: 1px;"></div> <span class="FiveDays" style="">5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> </div> <div class="DesktopMenuBar"> <div class="container"> <div class="row no-gutters"> <div class="col-auto mr-auto"> <div class="LeftMenu"> <div class="nav navbar-nav dropdown mmenu"> <ul><li><span><a href="/">Home</a></span></li> <li class="Parent nav-item dropdown"> <span><a href="/news/">News</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/news/business/">Business</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/your-say/">Your Say</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=1f260fe5-e40b-4ada-afd1-263c1a0e9a40" target="_blank">E-edition</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/sport/" class="selected">Sport</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/cricket/">Cricket</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/lifestyle/">Lifestyle</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/whats-on/">What's On</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/directory/">Directory</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="https://www.velvetmag.co.uk/" target="_blank">Velvet Mag</a></span> </li></ul> </div> </div> </div> <div class="col-auto p-2 pr-2"> <i class="fas fa-phone fa-flip-horizontal headnumber"></i> <a href="tel:01440-761307">01440 761307</a> </div> <div class="col-auto float-right text-right p-2 text-center LoginBtn account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> </div> </div> </div> </div> </header><div id="headerSpacer"></div> <div id="EwrapHead"></div> <div id="EWrap"> <div class="MainSite"> <div class="container white"> <div class="leaderboard text-center"> <div class="leader"><span id="ad_Head-Leader" class="advert" data-provider="3" data-devices="d" data-format="['billboard',970,1], ['lb1',728,90]"></span></div> <div class="banner"><span id="ad_Head-Banner" class="advert" data-provider="3" data-devices="t" data-format="['bannertablet',468,60]"></span></div> <div class="mobile"><span id="ad_Head-Mobile" class="advert" data-provider="3" data-devices="m" data-format="['bannermobile',320,50]"></span></div> </div> <div class="Bread text-center pt-4 pb-3"><p> <a href="/" class="first"><i class="fa fa-home icon-2x"></i> Home</a> <i class="fa fa-angle-right"></i>&nbsp; <a href="/sport/">Sport</a> <i class="fa fa-angle-right"></i>&nbsp; Article</p></div> </div><div class="container white"> <div class="row"> <div class="col-lg-8 ArticleInner"> <article><h1 class="HeadingFont">Gibbs at the double as Rovers end wait for win in the league</h1><hr /><div class="row"><div class="col-12 col-md-10 col-lg-10"><div class="authorName"><i class="fas fa-user-circle"></i> <span>By</span> Liam Apicella<div class="authorEmail mb-1"> <div class="divide">-</div> <a href="mailto:liam.apicella@iliffepublishing.co.uk">liam.apicella@iliffepublishing.co.uk</a></div>
</div><div class="clearfixNone"></div><div class="ArticleDate"><strong><i class="far fa-clock"></i> Published:</strong> 15:30, 30 October 2019 </div></div><div class="col-12 col-md-2 col-lg-2"></div></div><hr /><div class="row no-gutters SocialArticleIcons"><div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div><div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div><div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div><div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div><div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div><div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div><div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div></div><hr /><div class="pagestory"><!-- Article Start --><p>Just as he was not overly despondent by his side’s form since taking charge, manager James Bloomfield has no intention of getting too carried away by Haverhill Rovers’ impressive 2-1 win at Mildenhall Town on Tuesday evening.</p><p>It has been a baptism of fire for recently-appointed Bloomfield, whose first five games at the helm included a Turners Hyundai Suffolk Premier Cup clash with Step 3 outfit Needham Market, as well as tough trips to top six teams Newmarket Town and Woodbridge Town.</p><p>The new boss had picked up just one win during that time, yet positivity remained. And they were rewarded with the victory at Mildenhall, which came courtesy of a goal in either half from Ryan Gibbs after Rovers goalkeeper James Young had earlier put through his own net.</p><figure><img class="rthmb" src="/1x1.gif" alt="Football Mildenhall Town v Haverhill RoversFirst goal for Mildenhall. Picture by Mark Westley. (20440395)" data-root="/_media/img/" data-path="Q3ZWYV4AXQFU5BPOOBKL.jpg" data-ar="1.40"/><noscript><img src="/_media/img/Q3ZWYV4AXQFU5BPOOBKL.jpg" alt="Football Mildenhall Town v Haverhill RoversFirst goal for Mildenhall. Picture by Mark Westley. (20440395)"/></noscript><figcaption>Football Mildenhall Town v Haverhill RoversFirst goal for Mildenhall. Picture by Mark Westley. (20440395)</figcaption></figure><p>Bloomfield was proud of his young players and has now challenged them to build upon the confidence it has generated.</p><p>“Mildenhall are a good side and they will climb up the league, but it is just a bit of a rebuilding job for Ricky (Cornish, manager). They are an experienced, good side and while we are also a good side, we are largely inexperienced,” he said.</p><span id="ad_424122849" class="advert" data-provider="3" data-devices="t" data-format="['mpu1',300,250]"></span>
<span id="ad_189602296" class="advert" data-provider="3" data-devices="m" data-format="['mpu1',300,250]"></span>
<p>“But you have to find leaders in key moments and we started to find them out there tonight. I am very proud of them.</p><figure><img class="rthmb" src="/1x1.gif" alt="Football Mildenhall Town v Haverhill Rovers Ryan Gibbs with Haverhill&#39;s winner Picture by Mark Westley. (20440397)" data-root="/_media/img/" data-path="YARLRQJGMWDDHYC3HIDR.jpg" data-ar="1.40"/><noscript><img src="/_media/img/YARLRQJGMWDDHYC3HIDR.jpg" alt="Football Mildenhall Town v Haverhill Rovers Ryan Gibbs with Haverhill&#39;s winner Picture by Mark Westley. (20440397)"/></noscript><figcaption>Football Mildenhall Town v Haverhill Rovers Ryan Gibbs with Haverhill&#39;s winner Picture by Mark Westley. (20440397)</figcaption></figure><p>“We sat down with every player we recruited in the summer to ensure that we do have the characters in the dressing room because we were quite aware it is not going to be easy ride with a young side.</p><p>“We believe that having a side like this will allow us to climb the league in the long term. We do not have the budget to buy who we want so we have to create footballers.</p><span id="ad_905194344" class="advert" data-provider="3" data-devices="dt" data-format="['mpu2',300,250]"></span>
<span id="ad_209702329" class="advert" data-provider="3" data-devices="m" data-format="['mpu2',300,250]"></span>
<p>“The biggest thing for us is to not get too carried away. I know there has been a few losses on the bounce but I am not too interested in that record because the teams we have lost against, they are top teams like Newmarket away, Woodbridge away and Needham Market at home.</p><p>“We have had some good results this season like beating Godmanchester Rovers 6-2 and then we lost the next one, so we have to keep our feet on the ground.</p><div class="gallery-slider" data-imgSpacing="20" data-thumbSpacing="2" data-captionWidth="200" data-captionHeight="50" ><div class="slideshowOverlay"><h1>Gallery1</h1></div><img data-src="/_media/img/Z1SZ030I7M3AG45HMDWF.jpg" data-width="4211" data-height="2811" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Alex Steed Mildenhall Ben Tait HaverhillPicture by Mark Westley. (20440396)"/><img data-src="/_media/img/8DKZ2JD6GGD898MASEVU.jpg" data-width="3495" data-height="2496" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Picture by Mark Westley. (20440398)"/><img data-src="/_media/img/O4A7SF6LCWQ40Z8NE7DG.jpg" data-width="4214" data-height="3010" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Ryan Gibbs Picture by Mark Westley. (20440399)"/><img data-src="/_media/img/WZQ84O40B5ZNTXF816ZF.jpg" data-width="3600" data-height="2571" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Oliver Canfer Mildenhall Jemel Fox Haverhill Picture by Mark Westley. (20440400)"/><img data-src="/_media/img/1OD8TVUC673QMF655XB8.jpg" data-width="4211" data-height="2811" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Haverhill keeper James Young Picture by Mark Westley. (20440401)"/><img data-src="/_media/img/4YFHUTCGNTIOHFSVSLN0.jpg" data-width="3600" data-height="2572" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Ben Tait Haverhill. Picture by Mark Westley. (20440402)"/><img data-src="/_media/img/MZE5LP607SZVM5O3U3RC.jpg" data-width="3600" data-height="2571" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Oliver Canfer Mildenhall Jemel Fox Haverhill Picture by Mark Westley. (20440403)"/><img data-src="/_media/img/O5UUUXO15RJ3TWLBPTW8.jpg" data-width="3880" data-height="2771" data-isTrans="true" alt="Football Mildenhall Town v Haverhill Rovers Jemel Fox and Alfie Carroll Haverhill Jack Brame MildenhallPicture by Mark Westley. (20440404)"/></div><p>“Now we need to build on this win. I want them to take a bit of an ego hit from it – there is nothing wrong with that – and hopefully they lift themselves confidence-wise, but we need to keep working hard as well.”</p><p>The hosts, who won the reverse fixture 4-1 back in early September, broke the deadlock during a lacklustre first half in the 31st minute.</p><span id="ad_767849626" class="advert" data-provider="3" data-devices="t" data-format="['mpu3',300,250]"></span>
<span id="ad_953363852" class="advert" data-provider="3" data-devices="m" data-format="['mpu3',300,250]"></span>
<p>Joe Asensi’s in-swinging corner from the right drifted towards Young at the near post, but with a crowd of bodies in front of him, his intended punched clearance ended up in the back of the net.</p><p>Without a win from any of their previous six league games, Rovers could have wilted at this point, but to their credit they rallied and got themselves level in the 43rd minute through Gibbs’ composed finish.</p><p>And the forward was on target again 10 minutes after the restart, this time looping a header over home goalkeeper Jake Hayhoe.</p><p>As the half wore on Gibbs, Ben Tait and substitute Tomasz Siemienczuk all spurned chances to make the game safe, while up the other end Young made smart saves to thwart Jack Brame and Matt Green.</p><p>Haverhill: Young, Mills, Fox, Berkane, Carroll, Porter, Smalls (Dinnell 87'), Michaels, Tait (Siemienczuk 71'), Gibbs (Palmer 90=4'), Hall</p><p>Echo Man of the Match –Alfie Carroll: It was tough to not give this to Gibbs considering his two goals, but Carroll was a real leader for Rovers. Mildenhall sent in a number of crosses over the 90 minutes, many of which were cleared by the skipper.</p><p>* Haverhill (12th) travel to Thetford Town (16th) on Saturday (3pm) – a side they recently beat in the League Challenge Cup.</p><span id="ad_583294282" class="advert" data-provider="3" data-devices="d" data-format="['mpu3',300,250]"></span>
<span id="ad_197406664" class="advert" data-provider="3" data-devices="t" data-format="['mpu4',300,250]"></span>
<span id="ad_553475064" class="advert" data-provider="3" data-devices="m" data-format="['mpu4',300,250]"></span>
<!-- Article End --><div class="CatKey"><hr /><h5 class="Filled">Read more</h5><a href="/categories/football"class="article-category-link">Football</a></div></div><div class="BottomShare"><hr /><div class="row no-gutters SocialArticleIcons"><div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div><div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div><div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div><div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div><div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div><div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div><div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div></div><hr /></div><script type="text/javascript">$(document).ready(function() {siteResponsive.plugins.setTargetValue("articleid","384745");});</script><div class="clearfix"></div><div id="TaboolaMain"> <div id="taboola-below-article-thumbnails"></div> <div id="taboola-below-article-thumbnails-mobile"></div> </div> </article> </div> <div class="col-12 col-md-12 col-lg-4 sidebar"> <aside><style>@media screen and (max-width:769px){.ArticleSidebar{display:none!important}}</style> <div class="ArticleSidebar d-none d-sm-none d-md-block d-lg-block"> <div class="MPU mb-3 text-center"><span id="ad_MPU1" class="advert" data-provider="3" data-devices="d" data-format="['mpu1',300,250]"></span></div><div class="titleline_color mb-3"> <h3 class="title_color">MOST READ</h3> </div> <div class="clearfix"></div> <div class="fetchPanel" data-url="/Panels/Most-Read/"></div><div class="origami mb-3"> <div id="origami-ad-container"></div> <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="4db739fe-c596-428f-a7ec-6d8a895e0bd3"></script> </div><div class="MPU mb-3"><span id="ad_MPU4" class="advert" data-provider="3" data-devices="d" data-format="['mpu4',300,250]"></span></div> <div class="TaboolaSide mb-3 p-4 text-center"> <div id="taboola-right-rail-thumbnails"></div> </div> <div class="d-none d-sm-block d-md-block d-lg-block"><script src="//get.s-onetag.com/4357d25f-0b90-40b5-b8ec-b61b66b8ab43/tag.min.js" async="" defer=""></script></div></div></aside> </div> <div class="clearfix"></div> <div class="row"> <div class="col-12 col-sm-12 col-md-12 col-lg-12"><span id="ad_Teads" class="advert" data-provider="3" data-devices="dt" data-format="['teads',2,1]"></span><span id="ad_Teads-Mobile" class="advert" data-provider="3" data-devices="m" data-format="['teads',2,1]"></span></div> </div> </div> </div></div><footer> <div class="container"> <div class="row"> <div class="col-12 col-sm-6 col-lg-3"> <a href="http://iliffemedia.co.uk" target="_blank"> <img src="/_assets/iliffe_media_logo.png" class="img-fluid" alt="Iliffe Media Logo"/> </a> </div> <div class="col-12 col-sm-6 col-lg-9"> <div class="mt-3"> <a href="/rss-feeds/"><i class="fas fa-rss-square fa-2x" title="RSS"></i></a> <a href="https://www.facebook.com/Haverhill-Echo-744187595656988/" target="_blank"><i class="fab fa-facebook fa-2x" title="Facebook"></i></a> <a href="https://twitter.com/haverhill" target="_blank"><i class="fab fa-twitter-square fa-2x" title="Twitter"></i></a> </div> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row"> <div class="col-6 col-sm-3 col-lg-3"> <ul> <li><a href="http://iliffemedia.co.uk/about-us/" target="_blank">About</a> </li> <li><a href="/news">News</a> </li> <li><a href="/whats-on">What's On</a></li> </ul> </div> <div class="col-6 col-sm-3 col-lg-3"> <ul> <li><a href="/advertise-with-us">Advertise</a></li> <li><a href="/contact-us">Contact</a></li> <li><a href="/lifestyle">Lifestyle</a></li> </ul> </div> <div class="col-6 col-sm-3 col-lg-3"> <ul> <li><a href="/sport">Sport</a></li> <li><a href="https://www.imjobs.co.uk/jobs/haverhill/" target="_blank">Find Jobs in Haverhill</a></li> <li class="fconsent"><a href="javascript:window.cmpConfig.methods.summon()">Consent Preferences (EU user only)</a></li> </ul> </div> <div class="col-6 col-sm-3 col-lg-3"> <a href="https://www.ipso.co.uk/" target="_blank"><img src="/_assets/ipso_regulated.jpg" class="img-fluid IPSOLogo" alt="IPSO Regulated Logo"/></a> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row small"> <div class="col-md-6 col-lg-6 text-center text-lg-left">&#xA9;&nbsp;2019&nbsp;- Iliffe Media Publishing Ltd. All rights reserved.</div> <div class="col-md-6 col-lg-6 terms text-center text-lg-right"> <a href="http://iliffemedia.co.uk/terms-and-conditions/" target="_blank">Terms</a> - <a href="http://iliffemedia.co.uk/privacy-policy/" target="_blank">Privacy Policy</a> - <a href="/sitemap/">Sitemap</a> - <a href="/contact-us">Contact</a> </div> </div> </div> </footer><div id="clickSink"></div> <div id="cookiePopup"> <div class="container-fluid"> <div class="row"> <div class="col-9 col-md-10 col-lg-10"> <span class="cookietext"> This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies - <a class="learnmore" href="http://iliffemedia.co.uk/cookies-policy/" target="_blank">Learn More</a></span></div> <div class="col-3 col-md-2 col-lg-2 mt-2 mt-lg-0"> <a id="cookieClose" class="btn btn-secondary submit"> <i class="fas fa-check pr-1 pl-1"></i> AGREE</a> </div> </div> </div> </div><span id="ad_DHTML1" class="advert" data-provider="3" data-devices="dt" data-format="['dhtml1',1,1]"></span><span id="ad_DHTMLM1" class="advert" data-provider="3" data-devices="m" data-format="['dhtmlm1',1,1]"></span></div><script type="text/javascript">var elginConfig={map:{swLat:52.04853623237543,swLng:0.3846944828399046,neLat:52.11056867729665,neLng:0.4856313724883421}};</script> <div id="parsely-root" style="display: none"> <span id="parsely-cfg" data-parsely-site="haverhillecho.co.uk"></span> </div> <script>(function(k,g,a){var c=a.location.protocol,f=g+"-"+k,b=a.getElementById(f),j=a.getElementById(g+"-root"),l=c==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+g+".com";if(b){return}b=a.createElement(k);b.id=f;b.async=true;b.src=c+"//"+l+"/p.js";j.appendChild(b)})("script","parsely",document);</script>  <div id="parsely-root" style="display: none">
      <span id="parsely-cfg" data-parsely-site="haverhillecho.co.uk">      </span>
  </div>
    <script>
      (function(s, p, d) { 
 var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
      if (e) return;
      e = d.createElement(s); e.id = i; e.async = true;
      e.src = h+"//"+u+"/p.js"; r.appendChild(e);
      })("script", "parsely", document);
  </script>
  </body>
</html>
