<!DOCTYPE html>
<html lang="en" xml:lang="en">
  <head>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/>
    <link rel="amphtml" href="https://www.haverhillecho.co.uk/sport/amp/haverhill-set-stall-out-to-get-hands-on-cup-9117881/"/>
    <meta property="article:author" content="https://www.facebook.com/haverhillecho/"/>
    <meta property="article:published_time" content="2020-07-30Z13:02:00.0000000+01:00"/>
    <meta property="article:modified_time" content="2020-07-30Z13:03:22.9447690+01:00"/>
    <meta property="article:section" content="Cricket"/>
    <meta property="article:tag" content="Cricket"/>
    <link rel="canonical" href="https://www.haverhillecho.co.uk/sport/haverhill-set-stall-out-to-get-hands-on-cup-9117881/"/>
    <meta name="original-source" content="https://www.haverhillecho.co.uk/sport/haverhill-set-stall-out-to-get-hands-on-cup-9117881/"/>
    <meta property="og:url" content="https://www.haverhillecho.co.uk/sport/haverhill-set-stall-out-to-get-hands-on-cup-9117881/"/>
    <meta name="description" content="Return of competitive cricket is welcomed by Haverhill skipper Liam Botten as side target silverware."/>
    <meta property="fb:app_id" content="760098761053725"/>
    <meta name="keywords" content="Cricket"/>
    <meta property="og:locale" content="en_GB"/>
    <meta property="og:description" content="Return of competitive cricket is welcomed by Haverhill skipper Liam Botten as side target silverware."/>
    <meta property="og:title" content="Haverhill set stall out to get hands on cup"/>
    <meta property="og:type" content="article"/>
    <meta property="og:site_name" content="Haverhill Echo"/>
    <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "articleSection": "Sport",
        "headline": "Haverhill set stall out to get hands on cup",
        "keywords": [
          "Cricket"
        ],
        "thumbnailUrl": "https://www.haverhillecho.co.uk/_media/img/QM3GV8YXN4R54U26KF1V.jpg",
        "author": {
          "@type": "Person",
          "name": "Liam Apicella"
        },
        "creator": {
          "@type": "Person",
          "name": "Liam Apicella"
        },
        "publisher": {
          "@type": "Organization",
          "logo": {
            "@type": "ImageObject",
            "url": "https://www.haverhillecho.co.uk/site-logo.png"
          },
          "name": "Haverhill Echo"
        },
        "dateCreated": "2020-07-30T13:03:22Z",
        "dateModified": "2020-07-30T13:03:22Z",
        "datePublished": "2020-07-30T13:02:00Z",
        "image": "https://www.haverhillecho.co.uk/_media/img/QM3GV8YXN4R54U26KF1V.jpg",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": "https://www.haverhillecho.co.uk/sport/haverhill-set-stall-out-to-get-hands-on-cup-9117881/"
        },
        "url": "https://www.haverhillecho.co.uk/sport/haverhill-set-stall-out-to-get-hands-on-cup-9117881/"
      }
    </script>
    <meta property="og:image" content="https://www.haverhillecho.co.uk/_media/img/QM3GV8YXN4R54U26KF1V.jpg"/>
    <meta property="og:image:width" content="1253"/>
    <meta property="og:image:height" content="860"/>
    <title>Haverhill captain Liam Botten says goal is to win cup as competitive cricket returns</title>
    <meta name="twitter:card" content="summary_large_image"/>
    <meta name="twitter:site" content="@haverhill"/>
    <meta name="twitter:creator" content="@haverhill"/>
    <script type="text/javascript" src="/_bundles/iliffe-base-v5459639.js"></script>
    <link type="text/css" rel="stylesheet" href="/_resources/commentsv3-v5212245.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/font-awesome-svg-5.10.2-v5099857.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/iliffe_gallery_carousel-v4934161.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/iliffe-he-v5458700.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/WeatherIcons-v5511500.css"/>
    <script type="text/javascript" src="/_resources/common-v5137428.js"></script>
    <script type="text/javascript" src="//js-sec.indexww.com/ht/p/185246-98331710595893.js" async></script>
    <script type="text/javascript" src="https://cdn.conversant.mgr.consensu.org/gdpr/cmp/config/h/a/haverhillecho.co.uk/config.js"></script>
    <script type="text/javascript" src="/_resources/flux-v3.1.3-v5085464.js"></script>
    <script type="text/javascript" src="/_resources/iliffe_gallery_carousel-v4934147.js" defer></script>
    <script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script type="text/javascript" src="/_resources/moment-v5086699.js"></script>
    <script type="text/javascript" src="https://platform.twitter.com/widgets.js" async></script>
    <script type="text/javascript" src="/_resources/vue-v2.6.10-v5128841.js"></script>
    <script type="text/javascript" src="https://cdn.conversant.mgr.consensu.org/gdpr/cmp/gdpr-cmp-bootstrap.js"></script>
    <script type="text/javascript" src="/_resources/commentsv3-v5212245.js"></script>
    <script type="text/javascript" src="https://cdn.mediavoice.com/nativeads/script/klmedia/km_master.js" async></script>
    <script type="text/javascript">
      var GeoLocation = { lat: 39.0481, lng: -77.4728, src: "IP" };
    </script>
    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/apple-touch-icon-152x152-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/apple-touch-icon-144x144-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/apple-touch-icon-120x120-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/apple-touch-icon-114x114-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/apple-touch-icon-76x76-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/apple-touch-icon-72x72-precomposed.png">
    <link rel="apple-touch-icon-precomposed" href="/apple-touch-icon-precomposed.png">
    <script type="text/javascript">
      var pluginsConfig = {
        "Cmp" : true,
        "Comscore" : {
          "C1" : "2",
          "C2" : "6035892"
        },
        "Lotame" : {
          "Code" : "12965"
        },
        "Taboola" : {
          "Url" : "https://cdn.taboola.com/libtrc/mediaforceeurope-network/loader.js",
          "MobileSelector" : "taboola-below-article-thumbnails-mobile",
          "MobileFeed" : "Below Article Thumbnails Feed",
          "DesktopSidebarSelector" : "taboola-right-rail-thumbnails",
          "DesktopSidebarFeed" : "Right Rail Thumbnails",
          "DesktopBodySelector" : "taboola-below-article-thumbnails",
          "DesktopBodyFeed" : "Below Article Thumbnails Feed"
        }
      };
    </script>
    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-117714806-1', 'auto');
      ga('send', 'pageview');
    </script>
    <script type="text/javascript">
      var dfpConfig = { DesktopUnit: "~154725070~haverhillecho_desktop~sport", MobileUnit: "~154725070~haverhillecho_mobile~sport" };
    </script>
  </head>
  <body class="responsive">
<header id="header"> <div id="headerSearch"> <form class="search s top" method="get" action="/search/"> <div class="row"> <div class="offset-lg-3 col-lg-6"> <input class="typesearch sb" type="text" name="q" placeholder="What would you like to find?"/> <button type="submit" class="sbtn"><i class="fas fa-search fa-2x"></i></button> </div> </div> </form> </div><div class="mobilemenu d-lg-none"> <div class="row no-gutters mobilemenu navbar"> <div class="col-2 account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> <div class="col-6 col-sm-4 col-md-3"> <a class="navbar-brand m-0 p-0" href="/"> <img src="/_assets/haverhillecho.svg" class="img-fluid mx-auto d-block mainlogo" alt="Haverhill Echo"/></a> </div> <div class="col-1 searchmob"> <div id="dropmobile"><a class="btn-search droptoggle" data-toggle="collapse"><i class="fas fa-search"></i></a> </div> </div> <div class="col-2 white text-center"> <button type="button" class="navbar-toggler w-100" data-toggle="collapse" data-target=".navbar-collapseMobile">&#x2630;</button> </div> </div> <div class="collapse navbar-collapseMobile" id="navbarSupportedContentMobile"> <div> <div class="topmenu"> <div class="text-center mobilenumber"> <i class="fas fa-phone fa-flip-horizontal"></i> <a href="tel:01440-761307">01440 761307</a> </div> <div class="whitethindiv"></div> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="https://www.destinationeastanglia.co.uk" target="_blank">Destination East Anglia</a></li> <li>|</li> <li><a href="/announcements/">Announcements</a></li> <li>|</li> <li><a href="https://property.haverhillecho.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="http://haverhill.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="https://www.iliffemedia.co.uk/media-pack/" target="_blank">Media Info</a></li> <li>|</li> <li><a href="https://www.buryfreepress.co.uk/lifestyle/digital-theatre/" target="_blank">Digital Theatre</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> <li>|</li> <li><a href="/contact-us/">Contact us</a></li> <li>|</li> <li><a href="https://twitter.com/haverhill" target="_blank"><i class="fab fa-twitter"></i></a></li> <li>|</li> <li><a href="https://www.facebook.com/Haverhill-Echo-744187595656988/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> </ul> </div> <div class="clearfix"></div> <div class="row no-gutters mobweather pb-2"> <div class="mx-auto text-left width"><a href="/weather/"> <i class="wi wi-day-sunny float-left" alt="Clear Skies"></i> <div class="WeatherHomeInfo"> <span class="Temp">26&deg;</span><span class="TempLater"> | 10&deg; - 5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> <ul class="p-2 dropnav"><li><span><a href="/">Home</a></span></li> <li class="menuParent"> <span>News <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/">News</a></li> <li><a href="/news/business/">Business</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/network-haverhill/">Network Haverhill</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=1f260fe5-e40b-4ada-afd1-263c1a0e9a40" target="_blank">E-edition</a></li> </ul> </div> </li> <li class="menuParent"> <span>Coronavirus <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/coronavirus/">Coronavirus</a></li> <li><a href="/news/business-as-usual/">Business As Usual</a></li> <li><a href="/news/network-haverhill/">Network Haverhill</a></li> </ul> </div> </li> <li class="menuParent"> <span>Sport <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/sport/">Sport</a></li> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/cricket/">Cricket</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Lifestyle <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/lifestyle/">Lifestyle</a></li> </ul> </div> </li> <li class="menuParent"> <span>What's On <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/whats-on/">What's On</a></li> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Directory <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/directory/">Directory</a></li> </ul> </div> </li> <li class="menuParent"> <span>Jobs <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></li> </ul> </div> </li> <li class="menuParent"> <span>Business As Usual <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/business-as-usual/">Business As Usual</a></li> </ul> </div> </li> <li class="menuParent"> <span>Subscribe <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/subscribe/">Subscribe</a></li> </ul> </div> </li> <li class="menuParent"> <span>Contact <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/contact-us/">Contact</a></li> </ul> </div> </li></ul> </div> </div> </div><div class="desktopmenu d-none d-lg-block"> <nav class="navbar navbar-expand-lg navbar-light top" id="menu"> <div class="container"> <div class="row no-gutters w-100"> <div class="col-lg-11"> <div class="FirstMenu"> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="https://www.destinationeastanglia.co.uk" target="_blank">Destination East Anglia</a></li> <li>|</li> <li><a href="/announcements/" target="_blank">Announcements</a></li> <li>|</li> <li><a href="http://haverhill.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="https://property.haverhillecho.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=1f260fe5-e40b-4ada-afd1-263c1a0e9a40" target="_blank">E-edition</a></li> <li>|</li> <li><a href="https://www.iliffemedia.co.uk/media-pack/" target="_blank">Media Info</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> <li>|</li> <li><a href="https://www.buryfreepress.co.uk/lifestyle/digital-theatre/" target="_blank">Digital Theatre</a></li> </ul> </div> </div> <div class="col-lg-1 text-right socialsearch"> <ul> <li><a href="https://twitter.com/haverhill" target="_blank"><i class="fab fa-twitter"></i></a></li> <li><a href="https://www.facebook.com/Haverhill-Echo-744187595656988/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> <li class="d-none d-sm-block"> <div id="drop"><a class="btn-search droptoggle"><i class="fas fa-search"></i></a></div> </li> </ul> </div> </div> </div> </nav> <div class="LogoSection"> <div class="container"> <a href="/"> <img src="/_assets/haverhillecho.svg" alt="Haverhill Echo" class="main-logo"/></a> <div class="WeatherHome float-right d-none d-sm-none d-lg-block"><a href="/weather/"> <i class="wi wi-day-sunny float-left" alt="Clear Skies"></i> <div class="WeatherHomeInfo"> <span class="Temp">26&deg;</span><span class="TempLater">| 10&deg;</span> <div class="clearfix" style="height: 1px;"></div> <span class="FiveDays" style="">5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> </div> <div class="DesktopMenuBar"> <div class="container"> <div class="row no-gutters"> <div class="col-auto mr-auto"> <div class="LeftMenu"> <div class="nav navbar-nav dropdown mmenu"> <ul><li><span><a href="/">Home</a></span></li> <li class="Parent nav-item dropdown"> <span><a href="/news/">News</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/news/business/">Business</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/network-haverhill/">Network Haverhill</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=1f260fe5-e40b-4ada-afd1-263c1a0e9a40" target="_blank">E-edition</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/news/coronavirus/">Coronavirus</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/news/business-as-usual/">Business As Usual</a></li> <li><a href="/news/network-haverhill/">Network Haverhill</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/sport/" class="selected">Sport</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/cricket/">Cricket</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/lifestyle/">Lifestyle</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/whats-on/">What's On</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/directory/">Directory</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/news/business-as-usual/">Business As Usual</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/subscribe/">Subscribe</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/contact-us/">Contact</a></span> </li></ul> </div> </div> </div> <div class="col-auto p-2 pr-2"> <i class="fas fa-phone fa-flip-horizontal headnumber"></i> <a href="tel:01440-761307">01440 761307</a> </div> <div class="col-auto float-right text-right p-2 text-center LoginBtn account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> </div> </div> </div> </div> </header><div id="headerSpacer"></div> <div id="EwrapHead"></div> <div id="EWrap"> <div class="MainSite"> <div class="container white"> <div class="leaderboard text-center"> <div class="leader"><span id="ad_Head-Leader" class="advert" data-provider="3" data-devices="d" data-format="['billboard',970,1], ['lb1',728,90]"></span></div> <div class="banner"><span id="ad_Head-Banner" class="advert" data-provider="3" data-devices="t" data-format="['bannertablet',468,60]"></span></div> <div class="mobile"><span id="ad_Head-Mobile" class="advert" data-provider="3" data-devices="m" data-format="['bannermobile',320,50]"></span></div> </div> <div class="Bread text-center pt-4 pb-3"><p> <a href="/" class="first"><i class="fa fa-home icon-2x"></i> Home</a> <i class="fa fa-angle-right"></i>&nbsp; <a href="/sport/">Sport</a> <i class="fa fa-angle-right"></i>&nbsp; Article</p></div> </div><script type="text/javascript">$(document).ready(function(){$(".external").each(function(){var a=$(this);var c=a.find("iframe");if(c.length>0){var b=parseInt(c.attr("height"),10);if(!isNaN(b)){a.css({paddingBottom:"auto",height:b+"px"})}}})});</script> <div class="container white"> <div class="row"> <div class="col-lg-8 ArticleInner"> <article><script type="text/javascript">function loadGrids() {siteResponsive.loadArticlePanel(1, "/panels/top-stories/");}function loadFlourish(){var flourish = $(".flourish");if(flourish.length){console.log("load flourish embed");$.getScript("https://public.flourish.studio/resources/embed.js", function(){ });}}function agatePremiumContentRendered() {siteResponsive.refreshFeatures();$(".freePreviewFade").detach();twttr.widgets.load();loadGrids();loadFlourish();}$(document).ready(function() {loadGrids();});</script><h1 class="HeadingFont">Haverhill captain Liam Botten says goal is to win cup as competitive cricket returns</h1><hr /><div class="row"><div class="col-12 col-md-10 col-lg-10"><div class="authorName"><i class="fas fa-user-circle"></i> <span>By </span><a href="/authors/liam-apicella" >Liam Apicella</a><div class="authorEmail mb-1"> <div class="divide">-</div> <a href="mailto:liam.apicella@iliffepublishing.co.uk">liam.apicella@iliffepublishing.co.uk</a></div>
</div><div class="clearfixNone"></div><div class="ArticleDate"><strong><i class="far fa-clock"></i> Published:</strong> 14:02, 30 July 2020 </div><div class="ArticleDate"><strong><span class="divide">&nbsp;|&nbsp;</span>Updated:</strong> 14:03, 30 July 2020</div></div><div class="col-12 col-md-2 col-lg-2"></div></div><hr /><div class="row no-gutters SocialArticleIcons"><div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div><div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div><div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div><div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div><div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div><div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div><div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div></div><hr /><div class="pagestory"><!-- Article Start --><p>Even as recently as a fortnight ago, Haverhill Cricket Club were uncertain as to what type of matches – if any – they would be able to play in 2020.</p><p>The fear was that following the Marshall Hatchick Two Counties Championship’s decision to abandon the season due to Covid-19, they would be limited to arranging their own friendlies.</p><p>However, there is now a genuine buzz at Manor Road, with all three of Haverhill’s teams having a batch of exciting fixtures to look forward to over the coming weeks.</p><figure><img class="rthmb" src="/1x1.gif" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Jamie Boulton bowling Haverhill take a wicket caught Haverhill captain Liam Botten. .Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240133)" data-root="/_media/img/" data-path="YZ1RHZIUSVWX31V6WDZZ.jpg" data-ar="1.40"/><noscript><img src="/_media/img/YZ1RHZIUSVWX31V6WDZZ.jpg" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Jamie Boulton bowling Haverhill take a wicket caught Haverhill captain Liam Botten. .Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240133)"/></noscript><figcaption>HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Jamie Boulton bowling Haverhill take a wicket caught Haverhill captain Liam Botten. .Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240133)</figcaption></figure><p>For skipper Liam Botten and his first team, they have joined the Atkins and Crane Cup – a tournament organised by Suffolk coach Andy Northcote, named after the late Norman Atkins MBE and Paul Crane, who were well regarded within the local cricketing community.</p><p>Eight teams have been split in to two groups, with Haverhill coming up against Woolpit, Mildenhall II and Long Melford.</p><span id="ad_933374569" class="advert" data-provider="3" data-devices="t" data-format="['mpu1',300,250]"></span>
<span id="ad_256401609" class="advert" data-provider="3" data-devices="m" data-format="['mpu1',300,250]"></span>
<p>Sides will play home and away before a crossover finals day on September 12.</p><figure><img class="rthmb" src="/1x1.gif" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Jamie Boulton bowling Haverhill .Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240143)" data-root="/_media/img/" data-path="XESTU8YCJWSFZXO08FPX.jpg" data-ar="1.40"/><noscript><img src="/_media/img/XESTU8YCJWSFZXO08FPX.jpg" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Jamie Boulton bowling Haverhill .Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240143)"/></noscript><figcaption>HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Jamie Boulton bowling Haverhill .Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240143)</figcaption></figure><p>The hard work of Northcote has been a godsend for Botten, who is hoping his side can go on to make a real impact in the tournament.</p><p>“It’s brilliant. For the club to have secured at least seven competitive games is massive,” said Botten, who will take his side to Woolpit on Saturday for their opening encounter (12pm), having beaten Sawston & Babraham II in a warm-up at the weekend.</p><span id="ad_134303600" class="advert" data-provider="3" data-devices="dt" data-format="['mpu2',300,250]"></span>
<span id="ad_931502406" class="advert" data-provider="3" data-devices="m" data-format="['mpu2',300,250]"></span>
<p>“Andy has done a fantastic job. As you would expect from him, it’s been done in a professional manner. Everything is in writing, he’s sorted the fixtures and umpires and we will be trialling new balls that will be put to the Two Counties before next season.</p><p>“We want to be competitive and our goal is to try to win the cup.</p><figure><img class="rthmb" src="/1x1.gif" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Haverhill captain Liam Botten..Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240144)" data-root="/_media/img/" data-path="8022SOZFRQ494QRGRK7Q.jpg" data-ar="1.40"/><noscript><img src="/_media/img/8022SOZFRQ494QRGRK7Q.jpg" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Haverhill captain Liam Botten..Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240144)"/></noscript><figcaption>HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Haverhill captain Liam Botten..Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240144)</figcaption></figure><p>“We will be getting our best XI on the pitch each weekend to give us the best chance to win our <br/>matches.”</p><p>Mark Barrell (injured), Luke Youngs (work commitments) and Chris Palmer (unavailable) will not be taking part, but aside from that absent trio, Botten will have a full strength side to select from.</p><span id="ad_181623355" class="advert" data-provider="3" data-devices="t" data-format="['mpu3',300,250]"></span>
<span id="ad_556248989" class="advert" data-provider="3" data-devices="m" data-format="['mpu3',300,250]"></span>
<p>And for the young members of the team there is an added incentive to produce the goods, with the tournament’s top under-23 player – voted on by opposition teams – receiving a full set of Garrard & Flack kit as their prize.</p><figure><img class="rthmb" src="/1x1.gif" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Ollie North celebrates wicket..Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240127)" data-root="/_media/img/" data-path="UMKKAYB83QW4Z8SU2KR4.jpg" data-ar="1.40"/><noscript><img src="/_media/img/UMKKAYB83QW4Z8SU2KR4.jpg" alt="HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Ollie North celebrates wicket..Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240127)"/></noscript><figcaption>HAVERHILL: Cricket - Haverhill v Sawston &amp; Babraham II Ollie North celebrates wicket..Haverhill Cricket Club, Manor Rd, Haverhill Picture by Mark Westley. (39240127)</figcaption></figure><p>“The likes of Harry Harding, Will Bailey and Callum Brunning all stand a real chance,” added Botten.</p><p>“They are all capable of winning games of cricket and Will has already got a couple of 50s in the friendlies, so he’s started well.</p><p>“They already influence games so there is no reason why they can’t aim for it.</p><p>“It’s a great prize and it will encourage all teams to give some of the youngsters the exposure to a good level of cricket.”</p><p>Haverhill IIs, meanwhile, have entered into a tri-series alongside Little Bardfield and Dunmow, with the second string suffering a big home defeat to the latter on Saturday. They will be looking to bounce back at home to Little Bardfield this weekend (12.30pm), while the thirds also have a host of matches lined up.</p><p>“We are good friends with Bardfield and Dunmow, so it is great to have sorted something with them,” said Botten.</p><p>“Some of the younger players from the third team will hopefully play in that tournament.</p><p>“And the thirds have fixtures lined up until September 12, apart from one weekend.</p><p>“They’ll be playing the likes of Sudbury, Worlington and Brockley, who will be combining their IIs and IIIs, so it is going to be a good standard for them.”</p><p>Haverhill have also entered three teams into this year’s extended ‘Thank You NHS’ Suffolk Cup.</p><span id="ad_950456325" class="advert" data-provider="3" data-devices="d" data-format="['mpu3',300,250]"></span>
<span id="ad_793423728" class="advert" data-provider="3" data-devices="t" data-format="['mpu4',300,250]"></span>
<span id="ad_954582049" class="advert" data-provider="3" data-devices="m" data-format="['mpu4',300,250]"></span>
<!-- Article End --><div class="CatKey"><hr /><h5 class="Filled">Read more</h5><a href="/categories/cricket"class="article-category-link">Cricket</a></div><hr /><div><p class="Filled">More by this author</p><a href="/authors/liam-apicella"class="article-category-link"> Liam Apicella</a></div></div><hr /><div class="row"><div class="col-4 col-md-3"><a href="https://www.ipso.co.uk/" target="_blank"><img src="/_assets/ipsoarticle.jpg" class="img-fluid"/></a></div><div class="col-8 col-md-9"><div class="d-none d-sm-block clearfix"></div><p style="font-size: 13px; line-height: 14px; margin: 0; color: #aaa;">This website and its associated newspaper are members of the Independent Press Standards Organisation (IPSO)</p></div></div><hr /><div class="BottomShare"><div class="row no-gutters SocialArticleIcons"><div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div><div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div><div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div><div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div><div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div><div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div><div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div></div><hr /></div><script type="text/javascript">$(document).ready(function() {siteResponsive.plugins.setTargetValue("articleID","9117881");});</script><div class="clearfix"></div><div id="TaboolaMain"> <div id="taboola-below-article-thumbnails"></div> <div id="taboola-below-article-thumbnails-mobile"></div> </div> </article> </div> <div class="col-12 col-md-12 col-lg-4 sidebar"> <aside><style>@media screen and (max-width:769px){.ArticleSidebar{display:none!important}}</style> <div class="ArticleSidebar d-none d-sm-none d-md-block d-lg-block"> <div class="MPU mb-3 text-center"><span id="ad_MPU1" class="advert" data-provider="3" data-devices="d" data-format="['mpu1',300,250]"></span></div><div class="titleline_color mb-3"> <h3 class="title_color">MOST READ</h3> </div> <div class="clearfix"></div> <div class="fetchPanel" data-url="/Panels/Most-Read/"></div><div class="origami mb-3"> <div id="origami-ad-container"></div> <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="4db739fe-c596-428f-a7ec-6d8a895e0bd3"></script> </div><div class="MPU mb-3"><span id="ad_MPU4" class="advert" data-provider="3" data-devices="d" data-format="['mpu4',300,250]"></span></div> <div class="TaboolaSide mb-3 p-4 text-center"> <div id="taboola-right-rail-thumbnails"></div> </div> <div class="d-none d-sm-block d-md-block d-lg-block"><script src="//get.s-onetag.com/4357d25f-0b90-40b5-b8ec-b61b66b8ab43/tag.min.js" async="" defer=""></script></div></div></aside> </div> <div class="clearfix"></div> <div class="row"> <div class="col-12 col-sm-12 col-md-12 col-lg-12"><span id="ad_Teads" class="advert teads-advert" data-provider="3" data-devices="dt" data-format="['teads',2,1]" data-adsby="teads"></span><span id="ad_Teads-Mobile" class="advert teads-advert" data-provider="3" data-devices="m" data-format="['teads',2,1]" data-adsby="teads"></span></div> </div> </div> </div></div><footer> <div class="container"> <div class="row"> <div class="col-12 col-sm-6 col-lg-3"> <a href="http://iliffemedia.co.uk" target="_blank"> <img src="/_assets/iliffe_media_logo.png" class="img-fluid" alt="Iliffe Media Logo"/> </a> </div> <div class="col-12 col-sm-6 col-lg-9"> <div class="mt-3"> <a href="/rss-feeds/"><i class="fas fa-rss-square fa-2x" title="RSS"></i></a> <a href="https://www.facebook.com/Haverhill-Echo-744187595656988/" target="_blank"><i class="fab fa-facebook fa-2x" title="Facebook"></i></a> <a href="https://twitter.com/haverhill" target="_blank"><i class="fab fa-twitter-square fa-2x" title="Twitter"></i></a> </div> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row"> <div class="col-6 col-sm-3 col-lg-3"> <ul> <li><a href="http://iliffemedia.co.uk/about-us/" target="_blank">About</a> </li> <li><a href="/news">News</a> </li> <li><a href="/whats-on">What's On</a></li> </ul> </div> <div class="col-6 col-sm-3 col-lg-3"> <ul> <li><a href="/advertise-with-us">Advertise</a></li> <li><a href="/contact-us">Contact</a></li> <li><a href="/lifestyle">Lifestyle</a></li> </ul> </div> <div class="col-6 col-sm-3 col-lg-3"> <ul> <li><a href="/sport">Sport</a></li> <li><a href="https://www.imjobs.co.uk/jobs/haverhill/" target="_blank">Find Jobs in Haverhill</a></li> <li class="fconsent"><a href="javascript:window.cmpConfig.methods.summon()">Consent Preferences (EU user only)</a></li> </ul> </div> <div class="col-6 col-sm-3 col-lg-3"> <a href="https://www.ipso.co.uk/" target="_blank"><img src="/_assets/ipso_regulated.jpg" class="img-fluid IPSOLogo" alt="IPSO Regulated Logo"/></a> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row small"> <div class="col-md-6 col-lg-6 text-center text-lg-left">&#xA9;&nbsp;2020&nbsp;- Iliffe Media Publishing Ltd. All rights reserved.</div> <div class="col-md-6 col-lg-6 terms text-center text-lg-right"> <a href="http://iliffemedia.co.uk/terms-and-conditions/" target="_blank">Terms</a> - <a href="http://iliffemedia.co.uk/privacy-policy/" target="_blank">Privacy Policy</a> - <a href="/sitemap/">Sitemap</a> - <a href="/contact-us">Contact</a> </div> </div> </div> </footer><div id="clickSink"></div> <div id="cookiePopup"> <div class="container-fluid"> <div class="row"> <div class="col-9 col-md-10 col-lg-10"> <span class="cookietext"> This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies - <a class="learnmore" href="http://iliffemedia.co.uk/cookies-policy/" target="_blank">Learn More</a></span></div> <div class="col-3 col-md-2 col-lg-2 mt-2 mt-lg-0"> <a id="cookieClose" class="btn btn-secondary submit"> <i class="fas fa-check pr-1 pl-1"></i> AGREE</a> </div> </div> </div> </div><span id="ad_DHTML1" class="advert" data-provider="3" data-devices="dt" data-format="['dhtml1',1,1]"></span><span id="ad_DHTMLM1" class="advert" data-provider="3" data-devices="m" data-format="['dhtmlm1',1,1]"></span></div><script type="text/javascript">var elginConfig={map:{swLat:52.04853623237543,swLng:0.3846944828399046,neLat:52.11056867729665,neLng:0.4856313724883421}};</script>  <div id="parsely-root" style="display: none">
      <span id="parsely-cfg" data-parsely-site="haverhillecho.co.uk">      </span>
  </div>
    <script>
      (function(s, p, d) { 
 var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
      if (e) return;
      e = d.createElement(s); e.id = i; e.async = true;
      e.src = h+"//"+u+"/p.js"; r.appendChild(e);
      })("script", "parsely", document);
  </script>
    <script type="text/javascript" src="//d1hnzacu959ev8.cloudfront.net/app.min.js"></script>
    <script type="text/javascript" src="/_resources/MoneyPennyHE-v5488628.js"></script>
  </body>
</html>
